Lead Automation Actions – Messaging

1. Feature Overview

Automate the entire process of contacting your leads!
Send emails and SMS to leads at the opportune moment. For example,

  • Send a warm welcome message when a lead signs up on your website.
  • A nurturing email to engage a lead who visited a pricing page.
  • A thank you note after you’ve made a sale.
  • Send an automated email on special occasions/holidays.
  • And lots more…

LeadSquared Messaging Automation

 

2. Send Email

This allows you to send emails to leads based on the condition satisfied.

  1. After clicking the Add expand icon on the previous card, under Actions, click Messaging, then click Send Email.
  2. On the Choose an Email Template pop-up box, select an existing email template or create a new one.

Email template select

You’ll be directed back to the automation page and the send email action will be visible.

 

3. Send Opt-in Email

Email Opt-in settings help protect your lead’s privacy rights. By combining these settings with the email opt-in automation action, enable leads to choose whether or not they want to receive emails from your organization. To know more, refer to Data Protection and Privacy Settings.

LeadSquared Messaging Automation

 

4. Send SMS

Sending SMS through automation required you to first install and configure an SMS connector. See How to Send SMS using Automation, for all the details.

LeadSquared Messaging Automation

 

5. WhatsApp

To send automated WhatsApp messages to your leads, refer to Send WhatsApp messages using Automations.

LeadSquared Messaging Automation

 

6. Troubleshooting

Issue: Appointment times vary between text reminders and email reminders for users in different time zones.

Example:

Text Reminder

Automation Troubleshooting

Email Reminder

Automation Troubleshooting

Root Cause:
This discrepancy occurs due to expected platform behaviour:

  • Email Reminders: The “Send Email” card loads the appointment or DateTime values statically based on the company’s time zone set in the “Company Profile” settings. As a result, email reminders reflect the time according to the company’s time zone.
  • Text Reminders: The “Send Text” card dynamically pulls data from the LeadSquared database. The DateTime values are updated based on the user’s time zone, as the telephony connector maps the DateTime according to user-specific data.

Solution:
Enable the ‘Enable Automation Mail Merge as per ‘From’ User’s Time Zone in Email Cards’ advanced configuration settings shown below. If you can’t find the setting, contact us at support@leadsquared.com.

LeadSquared Automation Troubleshooting

 

Any Questions?

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