1. Feature Overview
You can import your leads into LeadSquared through a CSV (Comma Separated Value) file.
If you’re storing your lead data in a spreadsheet, database application or any other software, you’ll first have to export the leads to a CSV file and then follow the steps listed here.
Note:
- You can’t stop or undo a lead import once it starts.
- The default import limit through CSV is 25,000 leads. To extend this limit contact your account manager or write to support@leadsquared.com. It can be extended to a maximum of 300,000.
- You can also bulk-update lead fields through CSV (excel) import by selecting Overwrite duplicates or Update empty fields of duplicates in Import Setting (section 5).
2. Prerequisites
- The file type must be CSV.
If your data is stored in a Microsoft Excel file, save it as a Comma Separated Value (CSV) file. CSV content should not have comma (,) semicolon (;), pipe (|), tilde (~), back quote (`), caret (^) in the header. You can refer to Formats supported in Excel to learn more on how to save an excel file into CSV file. - Column names are mandatory.
You must enter column names in the CSV file. These are the different lead attributes or fields like First Name, Last Name, Email, etc. - Download the sample CSV file.
Download the sample CSV file to learn to understand how your file should be structured. - Create custom lead fields.
LeadSquared has standard system fields like First Name, Last Name, Email, Phone, etc. If you want to import custom lead attributes specific to your business like Budget, Examination Results, etc., you can create them by navigating to My Account>Settings>Customization>Lead Fields. For more information, see How to Create Custom Lead Fields.
Note:
- You can also import custom field sets (non file type fields). For example, if you have a parent lead field called ‘Identification Documents’ and the associated custom field set has the child field – ‘Status’, then pass – Identification Documents – Status
- Lead import supports prospect ID as a column header in the CSV file as well. This is useful when there are no unique fields configured in an account. Users can export the CSV, and use the Prospect ID to make updates and re-import the leads.
3. How it Works
- Upload the CSV file with your lead information.
- Map the CSV fields to the fields in your LeadSquared account.
- Choose how you want to handle duplicate lead records, select the lead owner, and choose lead sources.
- View the summary to check for errors.
4. Upload the CSV File
1. From the dashboard, navigate to Leads>Manage Leads, then click Import Leads.
2. Click the Click Upload CSV, select the file and upload it. Click Next once the file is uploaded.
If you’re not sure of how to arrange the data in the CSV file, click to download the sample CSV as highlighted below –
5. Map Fields
1. Click on the checkboxes alongside the fields you want to map. By default, all the checkboxes are selected. Select the field in your LeadSquared account from the drop-down on the right.
2. If a field in your CSV file doesn’t exist in your LeadSquared account, click Create New Field and define the field properties.
Note: You can also map Account Type and Account Name fields in your CSV to an account type and account name in LeadSquared.
- The Account Type you pass in the CSV must exist in your LeadSquared system.
- If you pass an existing account name, the lead will be added to that account.
- If you pass a new account name, a new account will be created in LeadSquared and the lead will be added to it.
6. Import Settings
Lead Import Rules
If a CSV file contains a lead with an email address that already exists in your LeadSquared account, the lead is considered to be a duplicate.
You have three options to handle duplicates –
- Ignore duplicates
If you select this option, duplicate records will not be imported. This is the default option that is pre-selected. - Overwrite duplicates
If you select this option, the CSV file data will overwrite the data in your LeadSquared account. The following checkboxes will also be available for selection.
- Import only if valid email exists in CSV
- Do not update owner of existing leads
- Do not create new leads – this will ensure leads are only updated and no new leads are created.
- Update empty fields of duplicates
With this option, only empty fields of the duplicate records in LeadSquared will be updated with the data in the CSV file.
Uncheck the Import only if valid email id exists in CSV if you want to import leads with invalid email addresses as well.
Here are some examples –
Assume that john.smith@acmecorp.com already exists in your LeadSquared account. The CSV file you’re importing also contains the same Email Id.
- If you select the ignore duplicates, the lead will not be imported.
- If you choose the overwrite duplicates, the lead fields you have chosen to map will update the existing lead in your account.
- For example, if you selected First Name, Company and Lead Stage, only these fields will be updated for the existing record. The new values in LeadSquared will be John, Acme Corp and Prospect.
- If you select update empty fields, lead fields which are empty in your LeadSquared account will be update.
- For example, if you have chosen to map Lead Stage, and that field is empty in for the lead in your account, then only the Lead Stage will be updated to Prospect. The remaining fields will remain the same.
Select List and Owner
- By default, the logged in user is displayed as the lead owner. You can change the lead owner from the drop-down.
- You can assign the leads to a list you’ve created, or you can create a new list. If you want to create a new list, enter the list name and a description. Alternatively, you can opt not to create a list during the import process.
- You can also assign tags to the imported leads. The tags can be used to filter the imported leads from the Manage Leads page.
Select Source
- You can specify the source (organic search, referral sites, etc.) from which you obtained your leads.
- The Import Summary Note option lets you enter text to specify details about the CSV file. For example, you could mention where you collected the data (Mall, Kiosk, Office, etc.), a partner you recieved the data from or even the old system (Zoho CRM, SalesForce, etc.)
7. Summary
If your file was successfully imported, you’ll see a success message.
Click the highlighted link to view the status of your lead import. You may click the actionsicon and select Send Import Report to receive an email with the details of your import.
Regardless of the Send Import Report option, once your import is complete, you’ll receive an email with a link to download your original CSV. This CSV will have two additional columns ‘ImportStatus’ and ‘ImportMessage’ to help you understand which records were imported/ignored. Correct the unprocessed records and restart the Import Leads process with the corrected file.
8. Data Formats
You may encounter some of the following situations –
- When your CSV files contain date fields, example ‘Contacted On’, ‘Followed Up On’, ‘Birthday’, and so on, you should ensure that you’ve created a matching custom field in your LeadSquared account.
For more information on how to create a custom field, see How to Create Custom Fields. Also, ensure that date fields have the correct format – dd/mm/yy or mm/dd/yy. - If your CSV file contains a field which can be represented through a drop-down, you could create a matching custom field to map it to during the import process.
- If the CSV file contains a lead field of type ‘Boolean’, you can create a matching custom field and then map the information during the import process. If the field is empty then, by default it is mapped as ‘NO’ in LeadSquared.
- For example, you may a lead field for ‘Valid Passport’. If a lead in your CSV file has an empty value for this column, it will get mapped as a ‘No’ in your LeadSquared account.
- If your CSV file contains a field for ‘Do Not Email‘ you can map it to the ‘Do Not Email’ field in your account.
Troubleshooting
Error: Unique Constraint Error During Lead Import
- Issue: Lead import is failing for some leads with the error message – “Unique Constraint Error”.
- Cause: If your account has two unique fields, such as Email and Phone, and both are being imported in the same row, the system may run into conflicts when it tries to match and update records.
- Example:
- Lead 1 has Phone P1 and Email E1.
- In LeadSquared, there are two separate leads: one with Phone P1 and another with Email E1.
- When you import using “Phone” as the search key, the system will find the lead with Phone P1 and try to update its Email to E1. However, since another lead already exists with Email E1, the import will fail with a unique constraint error.
- Resolution: Ensure that both unique fields (e.g., Email and Phone) match correctly in the same record to prevent this conflict during import.
Error: “Column Header must not be longer than 64 characters” Error During Lead Import
- Issue: While importing leads, users encounter an error pop-up stating, “Column Header must not be longer than 64 characters,” after uploading the file.
- Possible Causes:
- The CSV file has column headers exceeding the 64-character limit.
- The CSV file is not encoded in the correct format (UTF-8).
- Solution:
- Ensure the column header does not have text exceeding 64 characters. Use an application like ‘Notepad’ to format the text and remove unwanted characters.
- Ensure the file is saved in the correct format: CSV UTF-8 (Comma delimited) (*.csv). Follow these steps to save your file in the required format:
- Open the CSV file in MS Excel and click on the File tab.
- Select Export from the menu.
- Click Save As and choose a location.
- In the Save as type dropdown, select CSV UTF-8 (Comma delimited) (*.csv).
- Save the file and reattempt the import.
- If the file is correctly formatted, a green dot should appear, indicating it is ready for import.
FAQs
Why is there a time mismatch when I import leads?
The time mismatch occurs due to differences in user time zones. For example, if the user who created the list is in GMT-12 and another user viewing the list is in GMT+5:30, the “Created On” time will appear different. To ensure consistency, update the time zone of the user importing the list to match the desired time zone (e.g., GMT+5:30).
Any Questions?
We hope this article was helpful. Please leave us a comment below if you have more questions.
Is there a way to save the field mapping for next import? We do a weekly import with a large number of fields, but the mapping will be the same every time. Reusing the same mapping would be helpful.
Hi Susan.

We currently cannot save field mapping. However, if the field names in your uploaded CSV match exactly with those in LeadSquared, they will be automatically mapped.
For instance, in the image attached below, the fields that are checked are automatically mapped as the Leadsquared field names match with the field names in the CSV.
Thank you! I’ll try that on this week’s import.
I wish to edit the current leads that have been uploaded. For eg – The owner of a particular lead needs to be changed. Can I do it by importing a CSV file? I know how to edit it manually for every lead, but is it possible via CSV file?
Hello, Kunal.

Yes, you can update leads through Lead Import. While importing the leads, in the third step, select Overwrite duplicates.
What is the purpose of Mandatory: Do not update owner of existing Opportunities
Hi, Manoj.
This is a setting you’ll be able to access if you’ve selected Overwrite Duplicates while importing opportunities. This setting can ensure that the value in the ‘opportunity owner’ field will not be overwritten via import even if you have sent the same in the import file. . For example, let’s say you wish to import 5 opportunities. All 5 opps have different owners and you have sent updated owners for them in the import file. If you enable the option Mandatory: Do not update owner of existing Opportunities, the opportunity owners will not be updated as per the value sent in the import file and will remain intact as before. However, if you do disable the setting, all relevant opportunity fields will be updated as per the import file along with the opportunity owners also.
Hi, When I update leads in bulk through CSV, it does not trigger the lead creation webhook. Is there some setting that needs to be enabled for this?
Rajath
Hi, Rajath. LeadSquared does not trigger webhooks based on any bulk operations (such as Bulk Update Leads via CSV). If this changes in the future, we’ll keep you informed. Thanks!
Also if we have any automation set for lead create (not webhooks), the created leads also do not enter automation ?
Hey, YM. If the bulk trigger is enabled, and during Trigger Configuration, if you’ve enabled the Trigger on Import option, the automation will trigger.
How can we import remarks or comments into notes with respect to each lead from CSV.
Hi Guru,
You can directly add comments or remarks under the ‘Notes’ field in the CSV file. Download the sample CSV file if you’re still unsure.
How do we change the search key?
Hi Rohit,
You can only change the search key to a unique field in your account. While mapping the fields during CSV import, map the CSV file field to a unique field in your account. Click the ‘Make Search Key’ button that appears alongside the field. Hope this helps!